Download Report button currently unavailable

Incident Report for Kaisa

Resolved

A fix has now been deployed and reports can be downloaded again as normal. Sorry for the inconvenience and thank you for your patience!
Posted Jun 18, 2024 - 18:27 CEST

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 18, 2024 - 18:26 CEST

Investigating

We are currently investigating an issue preventing you from downloading Reports from our Explore tool. Our engineers are looking into this and we aim to have a solution as soon as possible.
Posted Jun 18, 2024 - 18:12 CEST
This incident affected: Kaisa Dashboard.