We can confirm this issue has been resolved, and everything is working as expected since 11:47 CEST.
Posted Sep 03, 2026 - 13:58 CEST
Monitoring
Our team is currently monitoring the issues, and we believe the calls are no longer affected. However, if you have any issues, please feel free to email us at support@kaisa.io
Posted Sep 03, 2026 - 12:17 CEST
Identified
One of our main telephone service providers is experiencing issues, and some of the calls may be failing. Countries that may have been affected are Spain, Italy and France. The issues has been identified, and we see that the traffic is back to normal, and everything is connecting successfully at the moment. We're sorry for the inconvenience, and if you have any issues, or questions, please feel free to email us at support@kaisa.io.
Posted Sep 03, 2026 - 12:01 CEST
This incident affected: Inbound Calls (Calls to Kaisa tracking numbers).