Issues with DNCS API

Incident Report for Kaisa

Resolved

We can confirm this incident is now resolved, and all our services are up and running correctly now. Our engineering team will maintain active monitoring to guarantee continued performance. Once again, we're sorry for the inconvenience this may have caused, and if you have any questions or need any help, feel free to contact us at support@kaisa.io.
Posted May 20, 2026 - 16:55 CEST

Monitoring

We want to inform you that our team has deployed a fix to resolve this issue. Everything appears to be running as expected, and we are continuing to monitor the situation closely.

If you have any question , please don't hesitate to reach out here support@kaisa.io
Posted May 20, 2026 - 16:21 CEST

Investigating

We are currently experiencing issues in our dynamic number generation and API requests. We are looking into the root cause from our side at the moment, and we are sorry for any inconvenience this may have caused. If you need any help, please contact us at support@kaisa.io.
Posted May 20, 2026 - 15:58 CEST
This incident affected: DNCS (Dynamic number functionalities).