Dynamic number solution experiencing errors

Incident Report for Kaisa

Resolved

This incident has been resolved.
Posted Dec 03, 2025 - 11:54 CET

Monitoring

We have deployed a fix, and we are currently monitoring the results to ensure stability.
Posted Dec 03, 2025 - 11:02 CET

Update

We are continuing to work on a fix for this issue.
Posted Dec 03, 2025 - 10:52 CET

Identified

Some requests to our backend using our DNCS API solution appear to be failing. We have located the issue, and a solution is currently being worked on. We apologise for the inconvenience, and if you have any questions, please get in touch with our support team at: support@kaisa.io
Posted Dec 03, 2025 - 10:51 CET
This incident affected: DNCS (Dynamic number functionalities).