Degraded performance on calls

Incident Report for Kaisa

Resolved

We can confirm this incident is now resolved and all calls are connecting as normal. Thank you for your patience!
Posted Aug 04, 2025 - 09:53 CEST

Monitoring

We can confirm an issue with our local provider in Germany experienced issues handling traffic and some calls may have failed or terminated unexpectedly. While our provider seems to have now resolved the issue, we believe calls may have been affected for 20-25 minutes while this was being corrected. As traffic goes back to normal, we are currently monitoring.
Posted Aug 04, 2025 - 09:44 CEST

Investigating

We are currently investigating this issue.
Posted Aug 04, 2025 - 09:32 CEST
This incident affected: Calls.