Issues connecting calls in The Netherlands

Incident Report for Kaisa

Resolved

Incident was resolved at 15:38 and traffic continued as normal from that time. Thank you for your patience!
Posted Dec 09, 2024 - 16:40 CET

Identified

Our carrier partner has identified the issue and they are working on a fix. We have seen an improvement in traffic and more calls connecting as normal.
Posted Dec 09, 2024 - 15:49 CET

Investigating

We are currently experiencing call connection issues in the Netherlands, as one of our local partners has network issues. This means some calls may not connect as intended in this country. We are currently in contact with our provider in order to ensure traffic resumes as quickly as possible.
Posted Dec 09, 2024 - 13:55 CET
This incident affected: Calls.