Some errors detected with our email processor

Incident Report for Kaisa

Resolved

All pending emails have now been resent. Thank you for your patience!
Posted Mar 30, 2026 - 11:44 CEST

Monitoring

A fix has been deployed and as of 11:07 no further issues have been detected. Our engineers are reviewing the errors in our end and working on a solution to re-send any emails that failed to be delivered due to this incident. We are sorry again for the inconvenience, and any questions please do reach out to support@kaisa.io
Posted Mar 30, 2026 - 11:30 CEST

Identified

We have noticed some errors in our Email service processor which means some email notifications from our Engagement Builder may not have been sent out as intended. Our engineers have discovered the root cause and are working on a fix to be deployed shortly. Sorry for any inconvenience caused.
Posted Mar 30, 2026 - 10:59 CEST
This incident affected: Engagement Builder - Events.