Issues with post call events and Engagement Builder.

Incident Report for Kaisa

Resolved

The affected services are back up and the issue is resolved
Posted Oct 15, 2025 - 20:32 CEST

Update

We are continuing to investigate this issue.
Posted Oct 15, 2025 - 13:43 CEST

Investigating

We are currently experiencing issues that may affect our Engagement Builder and some post-call events. We know the root cause and are actively working on a fix. If you have any questions, please contact our support team at: support@kaisa.io
Posted Oct 15, 2025 - 13:43 CEST
This incident affected: rest API and Engagement Builder - Events.