Calls failing to connect

Incident Report for Kaisa

Resolved

This incident has been resolved.
Posted Dec 19, 2024 - 17:19 CET

Monitoring

We have made some changes in our end and noticed a significant improvement in call performance. We continue working on this issue until resolved and monitoring. We will update when it's finally closed as resolved. Thank you for your patience.
Posted Dec 19, 2024 - 17:10 CET

Investigating

We are currently experiencing issues connecting some calls through our numbers, our engineers are investigating and we will do our best to have this resolved as soon as possible. We will update soon once we have more details, we appreciate your patience in the meantime.
Posted Dec 19, 2024 - 16:37 CET
This incident affected: Calls.