Kaisa dashboard - degraded performance

Incident Report for Kaisa

Resolved

This incident has been resolved.
Posted Mar 11, 2025 - 18:17 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 11, 2025 - 17:19 CET

Identified

We are currently experiencing data display problems in the platform; therefore, you may see lower than expected call volume in reports on this page. We have identified the problem, and once it is fixed, you will be able to see your full data.

Explore will show the correct information, but some of the visualizations and widgets may be inaccurate at this time.
Posted Mar 11, 2025 - 16:50 CET
This incident affected: Kaisa Dashboard.